Project

General

Profile

Bug #386

Conformance test installation problem on FreeBSD

Added by Jane Shaw almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
21.08.2013
Due date:
Estimated time:
Affected version:
5.1.0
Resolution:
Fixed

Description

Hello,

I tried to build strongSwan 5.1.0 (tried also with 5.0.4) on FreeBSD with conftest option enabled.

Build options: ./configure --enable-kernel-pfkey --enable-kernel-pfroute --enable-conftest --disable-tools --disable-scripts --disable-kernel-netlink

However, it fails. StrongSwan builds fine without option --enable-conftest.

Build log is attached. Please let me know where the problem is.

Regards,

Jane Shaw

conftestLog.txt (41.1 KB) conftestLog.txt Jane Shaw, 21.08.2013 11:12

Associated revisions

Revision 85ca2f74 (diff)
Added by Tobias Brunner almost 5 years ago

conftest: Disable reset_seq hook on systems other than Linux

Fixes #386.

History

#1 Updated by Tobias Brunner almost 5 years ago

  • Tracker changed from Issue to Bug
  • Status changed from New to Closed
  • Assignee set to Tobias Brunner
  • Priority changed from High to Normal
  • Target version set to 5.1.1
  • Resolution set to Fixed

The reset_seq hook implementation is very Linux/Netlink/XFRM specific and, therefore, does not work on FreeBSD. The FreeBSD kernel unfortunately does not provide an interface to change the sequence number of an IPsec SA, so providing an alternative implementation is currently not possible (at least not for the oseq functionality - setting it to zero would probably be possible by retrieving, deleting and reinstalling the SA - if you need that please file a feature request).

The associated patch fixes the compilation issue by disabling the hook.

#2 Updated by Jane Shaw almost 5 years ago

It works now! Thank you very much!

Also available in: Atom PDF