Project

General

Profile

Bug #651

Can not rotate strongswan filelog

Added by adam li over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
charon
Target version:
Start date:
14.07.2014
Due date:
Estimated time:
Affected version:
5.2.0
Resolution:
Fixed

Description

I replaced syslog with filelog, it works well.
I want to rotate the filelog, but When I moved the log file, and used 'kill -HUP charon_pid' or 'kill -HUP starter_pid', it can not re-created strongswan log file, I just found the error:

Jul 14 00:38:10 00[DMN] signal of type SIGHUP received. Reloading configuration
Jul 14 00:38:10 00[DMN] reloading config failed, keeping old

ipsec update also did not work.

My configs about filelog:

filelog {
/var/log/strongswan/strongswan.log {
default = 1
append = yes
flush_line = yes
ike_name = yes
time_format = %b %e %T
}
}

and Strongswan VPN function is normal.

Strongswan version: 5.1.2-0~10701+51~ubuntu12.04.1
OS : Ubuntu 12.04 LTS

Can you give me any hints ?


Related issues

Has duplicate Issue #711: charon does not recreate log files on SIGHUPClosed18.09.2014

Associated revisions

Revision 4c67f216 (diff)
Added by Martin Willi over 6 years ago

charon: Define STRONGSWAN_CONF to fix configuration reloading

Since 4b670a20 we require an explicit strongswan.conf to re-load configurations.
However, the define was missing in the build, breaking SIGHUP based config
reloading.

Fixes #651.

Revision da5d6592 (diff)
Added by Martin Willi over 6 years ago

charon: Define STRONGSWAN_CONF to fix configuration reloading

Since 4b670a20 we require an explicit strongswan.conf to re-load configurations.
However, the define was missing in the build, breaking SIGHUP based config
reloading.

Fixes #651.

Revision c30b471d (diff)
Added by Martin Willi over 6 years ago

settings: Use strongswan.conf used during library initialization for reload

Since 4b670a20 we require an explicit strongswan.conf to re-load configurations.
However, the define was missing in the build, breaking SIGHUP based config
reloading.

Fixes #651.

Revision e98b2c7e (diff)
Added by Martin Willi over 6 years ago

settings: Use strongswan.conf used during library initialization for reload

Since 4b670a20 we require an explicit strongswan.conf to re-load configurations.
However, the define was missing in the build, breaking SIGHUP based config
reloading.

Fixes #651.

Revision 049eed31 (diff)
Added by Martin Willi about 6 years ago

settings: Use strongswan.conf used during library initialization for reload

Since 4b670a20 we require an explicit strongswan.conf to re-load configurations.
However, the define was missing in the build, breaking SIGHUP based config
reloading.

Fixes #651.

Revision 5e6341bf (diff)
Added by Martin Willi about 6 years ago

settings: Use strongswan.conf used during library initialization for reload

Since 4b670a20 we require an explicit strongswan.conf to re-load configurations.
However, the define was missing in the build, breaking SIGHUP based config
reloading.

Fixes #651.

Revision 3af8746c (diff)
Added by Martin Willi about 6 years ago

settings: Use strongswan.conf used during library initialization for reload

Since 4b670a20 we require an explicit strongswan.conf to re-load configurations.
However, the define was missing in the build, breaking SIGHUP based config
reloading.

Fixes #651.

Revision 68da3bad (diff)
Added by Martin Willi about 6 years ago

settings: Use strongswan.conf used during library initialization for reload

Since 4b670a20 we require an explicit strongswan.conf to re-load configurations.
However, the define was missing in the build, breaking SIGHUP based config
reloading.

Fixes #651.

History

#1 Updated by Martin Willi over 6 years ago

  • Category set to charon
  • Status changed from New to Closed
  • Assignee changed from Andreas Steffen to Martin Willi
  • Target version set to 5.2.1
  • Affected version changed from 5.1.2 to 5.2.0
  • Resolution set to Fixed

Hi,

00[DMN] signal of type SIGHUP received. Reloading configuration
00[DMN] reloading config failed, keeping old

I could reproduce this issue on 5.2.0, looks like a regression that breaks configuration and logger reloading.

I've addressed it with the associated commit. Please be aware that the patch touches the build system, which requires that you have autotools installed to regenerate the Makefiles.

Strongswan version: 5.1.2-0~10701+51~ubuntu12.04.1

5.1.2 does not seem to be affected. So either this release is actually more close to 5.2.0 as the name indicates, or you can't reload the configuration for other reasons (bad syntax?).

Regards
Martin

#2 Updated by adam li over 6 years ago

I got '5.1.2-0~10701+51~ubuntu12.04.1' from there : https://launchpad.net/~strongswan/+archive/ubuntu/strongswan-daily, I think there is no 5.2.0.
I will try to build by myself.
Thanks for your reply.

#3 Updated by Tobias Brunner about 6 years ago

  • Has duplicate Issue #711: charon does not recreate log files on SIGHUP added

Also available in: Atom PDF