Project

General

Profile

Issue #3310

Packet loss observed at rekey, hence request for patch of Feature #1291

Added by Vijay Kumar Kothamasu 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Category:
-
Affected version:
5.1.3
Resolution:
Won't fix

Description

Hi,
We are using the Strongswan version 5.1.3. And we happen to observe packet loss at the time of rekey.
On exploring Strongswan website, I happen to see the known issue #1291. And this seems to be fixed in 5.5.3 and above.
So I request you to please point me to place where i can download the patch for Feature #1291 and apply on 5.1.3 code
and check the packet loss issue is fixed.
Below link describes the issue is fixed in 5.5.3
https://wiki.strongswan.org/issues/1291

Thanks a lot for your help.

Regards
Vijay


Related issues

Related to Feature #1291: Avoid packet loss during IKEv2 CHILD_SA rekeyingClosed

History

#1 Updated by Tobias Brunner 7 months ago

  • Related to Feature #1291: Avoid packet loss during IKEv2 CHILD_SA rekeying added

#2 Updated by Tobias Brunner 7 months ago

  • Status changed from New to Closed
  • Assignee set to Tobias Brunner
  • Priority changed from High to Normal
  • Resolution set to Won't fix

So I request you to please point me to place where i can download the patch for Feature #1291 and apply on 5.1.3 code
and check the packet loss issue is fixed.

There is no such patch (even if you created a patch for the merged changes for #1291, you'd have a hard time applying it to 5.1.3 - there were also several other improvements regarding rekeying in later releases). Please upgrade to a newer release (and not just 5.5.3, use a current release).

Also available in: Atom PDF