Project

General

Profile

Issue #2324

Specifying esp and ike for Linux 2.6.27

Added by Ravi Bhatt about 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
interoperability
Affected version:
5.5.2
Resolution:
Fixed

Description

I am using strongSwan 5.5.2, Linux 2.6.27.25, mips version and even though the tunnel gets created successfully, I am not able to send/receive traffic. After adding debugs to the Linux Kernel, I believe the issue is due to Linux kernel incorrectly using 128 bit (takes default:curve25519) instead of 96 bit truncation for SHA-256. Every where I see references for defining sha256_96. Nowhere I see a working example for older Linux versions.

I am trying to specify ike & esp with sha256_96. But the ipsec fails to establish the tunnel. I am trying to find an ipsec.conf example where ike & esp is explicitly specified for older Linux kernel but till now, I cannot find a single example.

Can someone please post an ipsec.conf example which explicitly forces to use 96 bit truncation?


Related issues

Related to Feature #1353: Support for 96-bit HMAC-SHA-256 using IANA integrity algorithm #12Closed

History

#1 Updated by Tobias Brunner about 3 years ago

  • Related to Feature #1353: Support for 96-bit HMAC-SHA-256 using IANA integrity algorithm #12 added

#2 Updated by Tobias Brunner about 3 years ago

  • Status changed from New to Feedback
  • Priority changed from High to Normal

I believe the issue is due to Linux kernel incorrectly using 128 bit (takes default:curve25519) instead of 96 bit truncation for SHA-256. Every where I see references for defining sha256_96.

It's the other way around. The correct truncation is 128-bit, but older Linux kernels did this incorrectly and truncated to 96-bit (it's actually still the default if the keying daemon does not set the truncation explicitly).

takes default:curve25519

Not sure how that's relevant.

I am trying to specify ike & esp with sha256_96.

Makes no sense for IKE, the problem is the kernel that truncates incorrectly.

Can someone please post an ipsec.conf example which explicitly forces to use 96 bit truncation?

If you are connecting two strongSwan hosts try to configure them both with sha256_96 (I'm not actually sure if current strongSwan versions can do that on older kernels as they will probably try to use an interface that the old kernel doesn't support, so you may have to patch the kernel-netlink plugin - so I'm not sure how useful sha256_96 actually is).

#3 Updated by Tobias Brunner about 2 years ago

  • Status changed from Feedback to Closed
  • Assignee set to Tobias Brunner
  • Resolution set to Fixed

Since 5.5.3 the incorrect truncation for HMAC-SHA256 may be used by enabling the sha256_96 option.

#4 Updated by Tobias Brunner about 2 years ago

  • Category changed from configuration to interoperability

Also available in: Atom PDF