Project

General

Profile

Bug #1213

Updated by Tobias Brunner about 5 years ago

Just upgraded from 5.3.3 where everything was working to 5.3.4. Now after one connection (which is successful) no other connections are possible.
Noticed this log line which only appears using 5.3.4:

<pre>
Nov 20 08:19:20 ip-172-31-20-201 charon: 00[DMN] waiting for signal failed: Interrupted system call
</pre>


ipsec statusall shows no output after the successful connection, if you try to reinitiate a connection with ipsec up conn it exits with exitcode 7.
The config was not changed after upgrade. Packages were build on Ubuntu 14.04.3 LTS exactly the same way as 5.3.3 which works.
Installed packages are:
<pre>
ii libstrongswan 5.3.4-0-2scale amd64 strongSwan utility and crypto library
ii strongswan 5.3.4-0-2scale all IPsec VPN solution metapackage
ii strongswan-ike 5.3.4-0-2scale amd64 strongSwan Internet Key Exchange (v2) daemon
ii strongswan-plugin-eap-radius 5.3.4-0-2scale amd64 strongSwan plugin for EAP interface to a RADIUS server
ii strongswan-plugin-openssl 5.3.4-0-2scale amd64 strongSwan plugin for OpenSSL
ii strongswan-plugin-xauth-generic 5.3.4-0-2scale amd64 strongSwan plugin for the generic XAuth backend
ii strongswan-starter 5.3.4-0-2scale amd64 strongSwan daemon starter and configuration file parser
</pre>


Running kernel version is 3.13.0-66-generic, version was build on this machine.
Config was not changed between 5.3.3 and 5.3.4, no differences in /etc/strongswan.d/. The only thing which is configured in /etc/strongswan.d/charon is eap-radius.conf.

Back