Project

General

Profile

Bug #65

Many UML tests fail

Added by Martin Willi almost 12 years ago. Updated almost 12 years ago.

Status:
Closed
Priority:
High
Category:
testing
Target version:
Start date:
Due date:
Estimated time:
Affected version:
5.9.0
Resolution:

Description

Hi,

In order to set up a test platform for my work, I tried to use Strongswan's UML test suite. All UML hosts seem to build fine, althought there are a few error messages, but many tests fail.

I investigated on the first test (ike/rw-cert), to find that the test fails when carol (192.168.0.100) and dave (192.168.0.200) try to ping alice's eth0 interface (10.1.0.10). The problem is that alice has eth1 connected to the same subnet with address 192.168.0.50. So alice see an ICMP ping on eth0 from 192.168.0.100 to 10.1.0.10, but as it expected to see 192.168.0.0/24 traffic coming from eth1, alice doesn't even try to reply on eth0 nor eth1 (I made tcpdump traces to check).

Alice's eth1 being connected to uml_switch0 on 192.168.0.0/24 subnet is then the cause of the test failure, and is contrary to UML test suite documentation where we can see that alice is only connected on uml_switch1 on eth0 interface.

Many tests failure may me related to this architecture change, I need to investigate on this to confirm.

I tried to run test suite from Strongswan release 4.2.7 and from Strongswan r4358 with the same problem.

Attached to this ticket is output from "make-testing" command launched yesterday evening and still running as I'm writing this ticket. I don't attach testing.conf, as it's the default one, with just the UMLTESTDIR parameter modified.

Regards,

Nicolas Pichon.

make_testing.log (13.3 KB) make_testing.log output from make_testing command Martin Willi, 03.10.2008 10:56

History

#1 Updated by Andreas Steffen almost 12 years ago

This is a well known problem that during the start up of the UML instances, alice's interface eth0 which is needed for the MOBIKE tests is not deactivated.

WORKAROUND:

log in manually on alice and execute the command:

/etc/init.d/net.eth1 stop

#2 Updated by Andreas Steffen almost 12 years ago

  • Status changed from New to Closed
  • Affected version set to fixed

fixed by Changeset r4370 which adds a 5 second wait before attempting to close down interface eth1 on alice.

Also available in: Atom PDF