Project

General

Profile

Bug #516

some ipsec pki commands segfault

Added by Anonymous over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
pki
Target version:
Start date:
16.02.2014
Due date:
Estimated time:
Affected version:
5.1.1
Resolution:
Fixed

Description

I have been following this guide to set up a CA for strongswan 5.1.1 on Alpine Linux. I get through everything fine until I reach the point where you have to create entity certificates. When I try to use the command listed:

ipsec pki --pub --in peerKey.der | ipsec pki --issue --cacert caCert.der --cakey caKey.der \
                                             --dn "C=CH, O=strongSwan, CN=peer" > peerCert.der

I get a segmentation fault message. The following shows in my syslog:

kern.info kernel: [177268.836878] pki[5938]: segfault at bc1a9d8 ip 00006ee4f057a17e sp 00007e47256c8420 error 4 in libuClibc-0.9.33.2.so[6ee4f0540000+75000]

I've used pki --self and pki --gen with no problems. I don't know why it segfaults when I do the above.

Associated revisions

Revision 09417da4 (diff)
Added by Tobias Brunner over 6 years ago

sshkey: uclibc only defines fmemopen(3) if _GNU_SOURCE is defined

Fixes #516.

Revision ab13364c (diff)
Added by Tobias Brunner over 6 years ago

uclibc only defines strndup(3) if _GNU_SOURCE is defined

References #516.

History

#1 Updated by Tobias Brunner over 6 years ago

  • Is duplicate of Bug #452: Run "ipsec pki" on Debian VPS got "Segmentation fault" error added

#2 Updated by Tobias Brunner over 6 years ago

  • Description updated (diff)
  • Category set to pki
  • Status changed from New to Rejected
  • Assignee set to Tobias Brunner
  • Resolution set to Duplicate

I think this is the same issue described in #452.

I've used pki --self and pki --gen with no problems.

Hm, I compiled 5.1.1 on Alpine Linux and pki segfaulted with those commands too. Not sure why they would work in your case.

Did you already try the release candidate for 5.1.2?

#3 Updated by Tobias Brunner over 6 years ago

  • Tracker changed from Issue to Bug
  • Status changed from Rejected to Closed
  • Target version set to 5.1.2
  • Resolution changed from Duplicate to Fixed

As mentioned on IRC, I was able to reproduce the issue. The associated commit fixes it.

#4 Updated by Tobias Brunner over 6 years ago

  • Is duplicate of deleted (Bug #452: Run "ipsec pki" on Debian VPS got "Segmentation fault" error)

Also available in: Atom PDF