Project

General

Profile

Issue #507

testing environment - freeradius

Added by Christian Liebscher over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
testing
Affected version:
dr|rc|master
Resolution:
Duplicate

Description

You may want to update your recipe for freeradius source:testing/scripts/recipes/003_freeradius.mk.
The currently used version 2.2.1 is not available for download anymore:

chroot /srv/strongswan-testing/build/loop make SWANVERSION=5.1.1 -C /root/shared/compile -f 003_freeradius.mk
make: Entering directory `/root/shared/compile'
wget ftp://ftp.freeradius.org/pub/freeradius/freeradius-server-2.2.1.tar.bz2
--2014-01-31 15:49:31--  ftp://ftp.freeradius.org/pub/freeradius/freeradius-server-2.2.1.tar.bz2
           => `freeradius-server-2.2.1.tar.bz2'
Resolving ftp.freeradius.org (ftp.freeradius.org)... 88.190.25.44
Connecting to ftp.freeradius.org (ftp.freeradius.org)|88.190.25.44|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /pub/freeradius ... done.
==> SIZE freeradius-server-2.2.1.tar.bz2 ... done.
==> PASV ... done.    ==> RETR freeradius-server-2.2.1.tar.bz2 ... 
No such file `freeradius-server-2.2.1.tar.bz2'.

make: *** [freeradius-server-2.2.1.tar.bz2] Error 8

I tried 2.2.3 but your patches won't work anymore:

tar xfj freeradius-server-2.2.3.tar.bz2
cd freeradius-server-2.2.3 && cat ../patches/freeradius-eap-sim-identity ../patches/freeradius-tnc-fhh | patch -p1
patching file src/modules/rlm_eap/types/rlm_eap_sim/rlm_eap_sim.c
patching file share/dictionary
Hunk #1 succeeded at 214 (offset 18 lines).
patching file share/dictionary.tncfhh
patching file src/modules/rlm_eap/types/rlm_eap_tnc/configure
patching file src/modules/rlm_eap/types/rlm_eap_tnc/configure.in
patching file src/modules/rlm_eap/types/rlm_eap_tnc/eap_tnc.c
patching file src/modules/rlm_eap/types/rlm_eap_tnc/eap_tnc.h
patching file src/modules/rlm_eap/types/rlm_eap_tnc/Makefile.in
Hunk #1 FAILED at 3.
1 out of 1 hunk FAILED -- saving rejects to file src/modules/rlm_eap/types/rlm_eap_tnc/Makefile.in.rej
patching file src/modules/rlm_eap/types/rlm_eap_tnc/rlm_eap_tnc.c
patching file src/modules/rlm_eap/types/rlm_eap_tnc/tncs_connect.c
patching file src/modules/rlm_eap/types/rlm_eap_tnc/tncs_connect.h
patching file src/modules/rlm_eap/types/rlm_eap_tnc/tncs.h
patching file src/modules/rlm_eap/types/rlm_eap_ttls/eap_ttls.h
patching file src/modules/rlm_eap/types/rlm_eap_ttls/rlm_eap_ttls.c
patching file src/modules/rlm_eap/types/rlm_eap_ttls/ttls.c
Hunk #1 succeeded at 590 (offset 5 lines).
Hunk #2 succeeded at 1228 (offset 5 lines).
Hunk #3 succeeded at 1351 (offset 5 lines).
make: *** [.freeradius-server-2.2.3-patches-applied] Error 1


Related issues

Is duplicate of Issue #483: Building test environment and freeradiusClosed09.01.2014

History

#1 Updated by Martin Willi over 6 years ago

  • Is duplicate of Issue #483: Building test environment and freeradius added

#2 Updated by Martin Willi over 6 years ago

  • Status changed from New to Closed
  • Assignee set to Martin Willi
  • Resolution set to Duplicate

#3 Updated by Martin Willi over 6 years ago

Fetching 2.2.1 from the "old" subdirectory works, see referenced issue.

Also available in: Atom PDF