Project

General

Profile

Bug #476

libchecksum.so built based-on install path

Added by Jonathan Davies over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
02.01.2014
Due date:
Estimated time:
Affected version:
5.1.1
Resolution:
Fixed

Description

Hello,

I have an issue where the Ubuntu packages for strongSwan cannot build the libchecksum.so file properly for the integrity tests:

https://launchpadlibrarian.net/161373420/buildlog_ubuntu-trusty-amd64.strongswan_5.1.1-0ubuntu17_UPLOADING.txt.gz (look for 'integrity test data').

checksum_builder appears to be looking for the libraries based on what it can find in:

$(SRC_ROOT)/src/checksum/.libs/lt-checksum_builder

...which all point at the final install paths of /usr/lib/ipsec/plugins/*, however, during the Debian package build process, these are located in:

$(SRC_ROOT)/debian/tmp/usr/lib/ipsec/plugins/

Would it be possible to create an option for checksum_builder, so that one is able to specify a directory for the library locations?

Associated revisions

Revision 2ff62bee (diff)
Added by Tobias Brunner over 6 years ago

checksum: Set rpath including DESTDIR for checksum_builder

This way libraries to which checksum_builder does not itself link,
like libtls and libradius, are found during DESTDIR installs.

Fixes #476.

History

#1 Updated by Tobias Brunner over 6 years ago

  • Tracker changed from Issue to Bug
  • Status changed from New to Resolved
  • Assignee set to Tobias Brunner
  • Target version set to 5.1.2
  • Resolution set to Fixed

Would it be possible to create an option for checksum_builder, so that one is able to specify a directory for the library locations?

It already works as intended for libraries, but not for plugins. The problem is that while PLUGINDIR, defined in source:src/checksum/Makefile.am, actually includes DESTDIR, checksum_builder is built before make install is called with DESTDIR set.

It should be fixed with 0773c7fd, which delays the building of checksum_builder (by putting it in EXTRA_PROGRAMS instead of noinst_PROGRAMS) until it is actually required during make install.

#2 Updated by Tobias Brunner over 6 years ago

The associated commit fixes another problem revealed by the recent build logs. Apparently, libraries checksum_builder did not link to (like libradius or libtls) were not found.

#3 Updated by Tobias Brunner over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF