Project

General

Profile

Issue #3520

Strongswan + Android 11: No data transfer via tunnel

Added by Christian W 4 months ago. Updated 30 days ago.

Status:
Closed
Priority:
Low
Category:
android
Affected version:
5.8.4
Resolution:
Can't reproduce

Description

Hello,

i just upgraded my Google Pixel 2 XL to the latest Android 11 beta and noticed that my VPNs are not accessible anymore. The connection to the site is established as usual, it looks like there is no traffic passing through the tunnel. Maybe it's worth to take a look before the release of Android 11.

I tried:
- reinstalling Strongswan
- wiping data/cache
- new configuration of the connections

I attached the log of the Strongswan-App, and some basic network information about the routes / interfaces on the android device with an established connection. My second android device (with Android 10) works just fine, so i

android-log.txt (7.43 KB) android-log.txt android routes and interfaces (tun1) Christian W, 20.07.2020 10:54
charon.log (6.89 KB) charon.log charon client log Christian W, 20.07.2020 10:54

History

#1 Updated by Tobias Brunner 4 months ago

  • Status changed from New to Feedback

I don't think we can do much about this. May just be Google messing things up once again (they keep doing that when it comes to the VpnService API). Or it's related to something else (e.g. different mobile provider).

#2 Updated by Tobias Brunner 30 days ago

  • Status changed from Feedback to Closed
  • Assignee set to Tobias Brunner
  • Resolution set to Can't reproduce

Also available in: Atom PDF