Project

General

Profile

Issue #3011

Strongswan instance

Added by ftv dev about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Affected version:
5.7.2
Resolution:
Duplicate

Description

I am setting up Strongswan and in my setup I have to tunnel from a subnet that are in a different network than strongswan.

left=2001:0db8:85a3:0000:0000:8a2e:0370:7334
leftid=<a public IP address>
leftsubnet=2111:0db8:85a3::/64
right=<public IP address of remote system>
rightid=<same ip as right>
rightsubnet=<same ip as right/64>

Unfortunately, Strongswan wasn't able to forward packets correctly even though that it is reaching them.

However, when I configure the left subnet to the same subnet strongswan instance belongs to, the association works and strongswan forward the packets without any issue.

example:

left=2001:0db8:85a3:0000:0000:8a2e:0370:7334
leftid=<a public IP address>
leftsubnet=2001:0db8:85a3::/64
right=<public IP address of remote system>
rightid=<same ip as right>
rightsubnet=<same ip as right/64>

I am wondering is this a limitation or I can fix it ?


Related issues

Is duplicate of Issue #3012: Strongswan issue with leftsubnet that is different than strongswan subnetClosed

History

#1 Updated by Noel Kuntze about 2 months ago

  • Is duplicate of Issue #3012: Strongswan issue with leftsubnet that is different than strongswan subnet added

#2 Updated by Noel Kuntze about 2 months ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Also available in: Atom PDF