Project

General

Profile

Issue #2989

Android client does not work on ChromeOS

Added by Josh Hill over 1 year ago. Updated over 1 year ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Category:
android
Affected version:
Resolution:

Description

When using the Android strongSwan client on ChromeOS, it connects and the tunnel comes up, however no traffic flows. The Chromebook loses all network connectivity until the VPN is disconnected.

Other Android VPN clients, such as OpenVPN, work correctly.

Software:
  • Pixelbook running ChromeOS 72.0.3626.122 with Android 7.1 for the Android subsystem. The issue also occurred on an older ChromeOS version that used Android 5.
  • strongSwan Android 2.1.0

History

#1 Updated by Tobias Brunner over 1 year ago

  • Status changed from New to Feedback

We use the VpnService API, if it doesn't work correctly on ChromeOS, report it to Google.

#2 Updated by Rainer Stumbaum over 1 year ago

Could the workaround from
https://bugs.chromium.org/p/chromium/issues/detail?id=864874
be the solution here?

#3 Updated by Tobias Brunner over 1 year ago

That seems to concern the built-in VPN client, not VPN apps.

#4 Updated by Rainer Stumbaum over 1 year ago

The above bug report is actually mentioned in this bug report
https://bugs.chromium.org/p/chromium/issues/detail?id=866179
as a work around for the non-functioning chrome://flags#arc-vpn integration.

#5 Updated by Rainer Stumbaum over 1 year ago

Just tried with a fresh Chromebook (Powerwash, chrome://flags#arc-vpn enabled, then installed Android StrongSwan app and configured a split tunnel IKEv2 VPN connection).
There is no route there in crosh and the VPN does not work.
https://bugs.chromium.org/p/chromium/issues/detail?id=866179 needs updating...

Also available in: Atom PDF