Project

General

Profile

Issue #2685

load-test plugin - SA deleted after few seconds

Added by Joseph DE BIASIO 11 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
configuration
Affected version:
5.6.2
Resolution:
No feedback

Description

I'm using load-test plugin to simulate multiple clients authenticating against a real ePDG/3GPP AAA server (EAP-AKA)
As SA is established, IPSec tunnel as well, I noticed that IKE client issues IKE Informational/DELETE after 2 seconds to responder (in that case ePDG) and session is removed.
Logs from charon.log report: 00[DMN] signal of type SIGINT received. Shutting down
OS: CentOS 7

Jun 19 09:15:55 07[MGR] checkout IKEv2 SA with SPIs 9daee4a4bb8bb856_i 0000000000000000_r
Jun 19 09:15:55 07[MGR] IKE_SA load-test1 successfully checked out
Jun 19 09:15:55 07[MGR] <load-test|1> checkin IKE_SA load-test1
Jun 19 09:15:55 07[MGR] <load-test|1> checkin of IKE_SA successful
Jun 19 09:15:55 14[JOB] got event, queuing job for execution
Jun 19 09:15:55 14[JOB] next event in 464ms, waiting
Jun 19 09:15:55 06[MGR] checkout IKEv2 SA with SPIs 9daee4a4bb8bb856_i 0148ce6d05b3800a_r
Jun 19 09:15:55 06[MGR] IKE_SA load-test1 successfully checked out
Jun 19 09:15:55 06[MGR] <load-test|1> checkin IKE_SA load-test1
Jun 19 09:15:55 06[MGR] <load-test|1> checkin of IKE_SA successful
Jun 19 09:15:55 14[JOB] got event, queuing job for execution
Jun 19 09:15:55 14[JOB] next event in 44ms, waiting
Jun 19 09:15:55 05[MGR] checkout IKEv2 SA with SPIs 3679606828d3ad77_i 0000000000000000_r
Jun 19 09:15:55 05[MGR] IKE_SA load-test2 successfully checked out
Jun 19 09:15:55 05[MGR] <load-test|2> checkin IKE_SA load-test2
Jun 19 09:15:55 05[MGR] <load-test|2> checkin of IKE_SA successful
Jun 19 09:15:55 14[JOB] got event, queuing job for execution
Jun 19 09:15:55 14[JOB] next event in 399ms, waiting
Jun 19 09:15:55 12[MGR] checkout IKEv2 SA with SPIs 3679606828d3ad77_i 0110ff5405be000a_r
Jun 19 09:15:55 12[MGR] IKE_SA load-test2 successfully checked out
Jun 19 09:15:55 12[MGR] <load-test|2> checkin IKE_SA load-test2
Jun 19 09:15:55 12[MGR] <load-test|2> checkin of IKE_SA successful
Jun 19 09:15:55 00[DMN] signal of type SIGINT received. Shutting down

Any idea of what may cause SIGINT signal to delete IKE_SA ?

load-tester.conf (4.19 KB) load-tester.conf loat-test plugin configuration file Joseph DE BIASIO, 19.06.2018 09:50
charon.zip (173 KB) charon.zip charon.log archive Joseph DE BIASIO, 19.06.2018 09:50

History

#1 Updated by Tobias Brunner 11 months ago

  • Status changed from New to Feedback

What exactly are you referring to? The only DELETEs I see in the log are the ones sent after you terminated the daemon (the SIGINT you refer to).

#2 Updated by Noel Kuntze 4 months ago

  • Category set to configuration
  • Status changed from Feedback to Closed
  • Resolution set to No feedback

Also available in: Atom PDF