Project

General

Profile

Issue #2667

Feature #2095 - Support liveness check in Strongswan

Added by Leela Mohan Peruboina about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Affected version:
5.1.2
Resolution:
Duplicate

Description

Hi,

Do you have any plan to support liveness check with TIMEOUT_PERIOD_FOR_LIVENESS_CHECK attribute in 3GPP 24.302 in Strongswan?

The UE may support the TIMEOUT_PERIOD_FOR_LIVENESS_CHECK attribute as specified in subclause 8.2.4.2. If the UE supports the TIMEOUT_PERIOD_FOR_LIVENESS_CHECK attribute, the UE shall include the IMEOUT_PERIOD_FOR_LIVENESS_CHECK attribute indicating support of receiving timeout period for liveness check in the CFG_REQUEST configuration payload. If the TIMEOUT_PERIOD_FOR_LIVENESS_CHECK attribute as specified in subclause 8.2.4.2 indicating the timeout period for the liveness check is included in the CFG_REPLY configuration payload or if the UE has a pre-configured timeout period, the UE shall perform the tunnel liveness checks as described in subclause 7.2.2A.
NOTE: The timeout period for liveness check is pre-configured in the UE in implementation-specific way

Thank You.
Leela Mohan P


Related issues

Is duplicate of Feature #2095: Support liveness check in StrongswanFeedback29.08.2016

History

#1 Updated by Tobias Brunner about 4 years ago

  • Is duplicate of Feature #2095: Support liveness check in Strongswan added

#2 Updated by Tobias Brunner about 4 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

#3 Updated by Leela Mohan Peruboina about 4 years ago

Dear Tobias Brunner,

Thank you for reply.

Can you please share the change set for support liveness check.

#4 Updated by Tobias Brunner about 4 years ago

Can you please share the change set for support liveness check.

Did you even look at #2095? It's not yet implemented.

#5 Updated by Leela Mohan Peruboina about 4 years ago

Tobias Brunner wrote:

Can you please share the change set for support liveness check.

Did you even look at #2095? It's not yet implemented.

Thank you for reply.
I have gone through #2095 and understood that it is not implemented.
But as I was confused by your first comment "Is duplicate of Feature #2095: Support liveness check in Strongswan added". I thought the feature is added. so asked for change set.

Is there any plan to support this feature ?

#6 Updated by Tobias Brunner about 4 years ago

Is there any plan to support this feature ?

It's a duplicate of the existing issue so what I wrote still applies. If you are really interesting in this feature, you might want to consider sponsoring it's development.

Also available in: Atom PDF