Project

General

Profile

Issue #2632

Support for MOBIKE in NetworkManager plugin

Added by Mirek Svoboda about 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
networkmanager (charon-nm)
Affected version:
5.6.2
Resolution:
No feedback

Description

Currently, when network connectivity changes while using Gnome with NetworkManager plugin for Strongswan, the VPN connection facilitated by charon-nm is stopped even though MOBIKE is supported on server side.
Roaming among various internet connections while keeping VPN connection established works only when IPsec connection is initiated from command line, using regular charon.
The new feature proposed is to keep the VPN connection established and support roaming among internet connections if connection is established via NetworkManager in Gnome and charon-nm and MOBIKE support is provided on server side.

Affected versions of relevant components:
strongswan-charon-nm-5.6.2-2.fc28.x86_64
strongswan-5.6.2-2.fc28.x86_64
gnome-shell-3.28.0-1.fc28.x86_64
NetworkManager-strongswan-gnome-1.4.3-1.fc28.x86_64
NetworkManager-strongswan-1.4.3-1.fc28.x86_64

History

#1 Updated by Tobias Brunner about 4 years ago

  • Status changed from New to Feedback

The daemon is basically the same (differently configured, sure, but MOBIKE isn't disabled or anything), so this might not be directly related to strongSwan. Maybe it's just that NM doesn't support this (i.e. it forcefully stops the VPN process). Try finding out what exactly happens when the connectivity changes (NM should log what it does).

#2 Updated by Tobias Brunner about 3 years ago

  • Tracker changed from Feature to Issue
  • Status changed from Feedback to Closed
  • Assignee set to Tobias Brunner
  • Start date deleted (13.04.2018)
  • Resolution set to No feedback
  • Affected version set to 5.6.2

#3 Updated by Mirek Svoboda about 3 years ago

The issue is still present, my bad I was not able to collect additional info.
Version affected:
strongswan-charon-nm-5.7.2
NetworkManager-strongswan-1.4.4

Also available in: Atom PDF