Project

General

Profile

Bug #257

Charon: IKEv1 not sending Acct-Status-Type = Stop to RADIUS server after DPD timeout

Added by Khaos Tian over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
libcharon
Target version:
Start date:
03.12.2012
Due date:
Estimated time:
Affected version:
5.0.1
Resolution:
Fixed

Description

It happened on Charon IKEv1 with xauth-eap enabled. When DPD timeout, Charon will not send an Accounting-Request contains "Acct-Status-Type = Stop" to RADIUS server. This might cause miss accounting on RADIUS server.

257.patch (459 Bytes) 257.patch Khaos Tian, 03.12.2012 17:52

History

#1 Updated by Khaos Tian over 6 years ago

A patch basically fixed this problem. It seems the same problem also happens on IKEv2 side.

#2 Updated by Martin Willi over 6 years ago

  • Category set to libcharon
  • Status changed from New to Closed
  • Assignee set to Martin Willi
  • Target version set to 5.0.2
  • Resolution set to Fixed

A patch basically fixed this problem.

Looks good, I pushed this fix to master, thanks.

It seems the same problem also happens on IKEv2 side.

I couldn't reproduce this; IKEv2 DPD uses a different code path and invokes the hook correctly here.

Also available in: Atom PDF