Project

General

Profile

Issue #2541

Virtual IPs are not compatible with start_action=trap

Added by Luka Logar almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
kernel-interface
Affected version:
5.6.1
Resolution:
Duplicate

Description

I've noticed that roadwarrior fails to install source routes for the obtained virtual IP
as there already exist source routes for the remote_ts with the old/true IP (created during trap installation) -
add_route() ... manage_srcroute(this, RTM_NEWROUTE, NLM_F_CREATE | NLM_F_EXCL, ...) fails with EEXIST...

strongSwan 5.6.2dr4, running on Linux 4.14.18 kernel, using kernel_netlink plugin...


Related issues

Is duplicate of Feature #2162: Support for trap policies (auto=route) with virtual IPsClosed

History

#1 Updated by Tobias Brunner almost 2 years ago

  • Category set to kernel-interface
  • Status changed from New to Closed
  • Resolution set to Duplicate

#2 Updated by Tobias Brunner almost 2 years ago

  • Is duplicate of Feature #2162: Support for trap policies (auto=route) with virtual IPs added

Also available in: Atom PDF