Project

General

Profile

Bug #2251

Strongswan crashes under Lineageos 14.1

Added by Markus d112 over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Category:
android
Target version:
Start date:
15.02.2017
Due date:
Estimated time:
Affected version:
5.5.1
Resolution:
Fixed

Description

I am using Strongswan Version 1.8.1 under Android Lineageos 14.1-20170213-NIGHTLY-crackling and it crashes each time I disconnect a VPN connection: it doesn't respond any longer until a timeout where I can hardly kill the app or send a crash report (which I have done several times so you should see the reports in your system)

With CM13.1 it has worked fine, the problem occurs until upgrade to Lineageos 14.1

History

#1 Updated by Tobias Brunner over 1 year ago

  • Status changed from New to Feedback
  • Priority changed from High to Normal

With CM13.1 it has worked fine, the problem occurs until upgrade to Lineageos 14.1

Strange. Maybe triggered by a regression in their system. Did you contact them?

which I have done several times so you should see the reports in your system

I see a couple of dumps for an ANR, which I assume are from you, but they are not conclusive. I do have a vague idea for a workaround, though. Since I can't reproduce the problem it's difficult to test though (if you like you could send me the email address of your Google Play account so I can setup a closed alpha test).

#2 Updated by Markus d112 over 1 year ago

I have sent you a private mail with my google account name. I will try to reproduce the issue on a Motorola Moto G4 with Lineagos 14.1 the weekend. No, I didn't contact the lineageos team so far...

#3 Updated by Tobias Brunner over 1 year ago

  • Tracker changed from Issue to Bug
  • Status changed from Feedback to Closed
  • Assignee set to Tobias Brunner
  • Target version set to 5.5.2
  • Resolution set to Fixed

Fixed with version 1.8.2 of the app.

Also available in: Atom PDF