Project

General

Profile

Issue #2219

vpn under lubuntu-16.04

Added by volker kempter almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
networkmanager (charon-nm)
Affected version:
5.3.5
Resolution:
No change required

Description

VPN cannot established anymore under lubuntu-16.04.

From GUI (network-manager):

-> network connections ->vpn -> strongswan -> "bearbeiten" -> error: "vpn - extension service (Erweiterungsdienst) for org.freedesktop.networkmanager.strongswan could not be found".
So far, the behavior appears to be the same as was reported in bug #1406.

However, other than in #1406, vpn can also NOT be established via "sudo ipsec restart" and "sudo ipsec up ...".

Thus at present a vpn connection cannot be established at all!

Strongswan version is 5.3.5-1ubuntu3. Network-manager version is 1.2.2ubuntu016.04.3; replacing it by the older version 1.1.93 has no effect.

Last successful setup of VPN for the present configuration: 4 weeks ago.


Related issues

Is duplicate of Issue #2218: vpn under lubuntu-16.04Closed13.01.2017

History

#1 Updated by Noel Kuntze almost 4 years ago

That's a problem with lubuntu or your network manager version. Maybe a file is missing or something. Obviously, log files are required to figure out why it doesn't work and what changed. So please provide logs of what happen when you try to start it using ipsec, what versions of networkmanager, networkmanager-strongswan and strongswan you're using. Please keep in mind that networkmanager-strongswan and strongswan itself are different binaries and they are not interchangeable. networkmanager-strongswan does not call the charon binary. It calls charon-nm, which is internally different and special to support networkmanager.

#2 Updated by Tobias Brunner almost 4 years ago

  • Is duplicate of Issue #2218: vpn under lubuntu-16.04 added

#3 Updated by volker kempter almost 4 years ago

ad #1

please be more specific which log files you wish me to report. I could provide you with the output of "grep charon /var/log".
Or with the console output of "sudo ipsec up <server>".

Please understand that my possibilities are limited because the network-manager does not detect the strongswan vpn!

I provided you already with the version of strongswan (5.3.5-1ubuntu3), network-manager (1.2.2-ubuntu16.04.3); the version of the network-manager-strongswan is 1.3.1-1ubuntu1.

Please tell me whether you consider it as useful that I file a bug report at launchpad against the network-manager. However, remember that I downgraded the network-manager from version 1.2.2 to version 1.1.93 with no effect.

#4 Updated by Noel Kuntze almost 4 years ago

volker kempter wrote:

please be more specific which log files you wish me to report. I could provide you with the output of "grep charon /var/log".
Or with the console output of "sudo ipsec up <server>".

I'd like to see both, please. Obviously, charon/"ipsec" does not take the configuration you have in networkmanager.

Please understand that my possibilities are limited because the network-manager does not detect the strongswan vpn!

I provided you already with the version of strongswan (5.3.5-1ubuntu3), network-manager (1.2.2-ubuntu16.04.3); the version of the network-manager-strongswan is 1.3.1-1ubuntu1.

Okay, I did not spot that in the original text, thank you. I guess you should report those issues to canonical via launchpad.

Please tell me whether you consider it as useful that I file a bug report at launchpad against the network-manager. However, remember that I downgraded the network-manager from version 1.2.2 to version 1.1.93 with no effect.

Please open a bug report at launchpad against networkmanager-strongswan. I think it's the way you should proceed with this.

#5 Updated by Tobias Brunner almost 4 years ago

  • Status changed from New to Feedback

please be more specific which log files you wish me to report. I could provide you with the output of "grep charon /var/log".
Or with the console output of "sudo ipsec up <server>".

You might want to start reading that log yourself to identify obvious errors. Starting the daemon with ipsec start and a connection with ipsec up is in no way related to NetworkManager (the NM plugin uses its own backend, charon-nm, not the default daemon, charon), the same goes for the configuration.

I provided you already with the version of strongswan (5.3.5-1ubuntu3), network-manager (1.2.2-ubuntu16.04.3); the version of the network-manager-strongswan is 1.3.1-1ubuntu1.

As documented in other places only version 1.4.0+ of the NM plugin is compatible with NM 1.2+. So 1.3.1 won't work (there seem already several issues reported on Launchpad).

However, remember that I downgraded the network-manager from version 1.2.2 to version 1.1.93 with no effect.

Why should it have any effect, 1.1.93 is actually 1.2-rc1.

#6 Updated by volker kempter almost 4 years ago

ad #5:
thank you for the detailed comments.

I have followed the recent launchpad reports connected with strongswan vpn. #1570352 was initiated by myself: for me it was solved with the network-manager-gnome, v 1.2.0 package. At that time, the connection via "ipsec" still worked even though a connection via the networ-manager could not be set up.

This time nothing works; I also cannot connect via ipsec.

#7 Updated by volker kempter almost 4 years ago

ad #5 (again)
#As documented in other places only version 1.4.0+ of the NM plugin is compatible with NM 1.2+. So 1.3.1 won't work#

As a consequence of this statement, I upgraded to version 1.4.1 of the NM plugin via the ppa:launchpad.net/develer/strongswan/ubuntu (using only packages intended for ubuntu-16.04).
I ended up with a mixed (broken) installation featuring simultaneously packages of versions 5.3.5 and 5.5, 4 broken packages as well as unmet dependencies.

Meanwhile, I learned that the my strongswan server (TU Clausthal / Germany) has problems and that VPN with that server does not work at all! These problems appear not to be solved as yet...

#8 Updated by volker kempter over 3 years ago

ad #7:
meanwhile the problems of my vpn server have apparently been solved. The vpn connection from the console via ipsec works again under ubuntu -16.04 (with my old installation of strongswan v5.3.5). However, the vpn connection from the GUI with the network-manager does not work anymore. I'm left with exactly the same behaviour as described in #1406 (see also #1429):from the network-manager I'm getting the message "VPN-Erweiterungsdienstfür org.free.desktop.NetworkManger.strongswan konnte nicht gefunden werden".

I decided to replace strongswan v5.3.5 by v5.5 which is possible under ubuntu 16.04 with the ppa:develer/strongswan. One has to be careful not to end up with an installation having a mixture of 5.3.5 and 5.5 components (see above).

With this workaround strongswan-vpn, v5.5, works now under ubuntu 16.04 both from the console and with the network-manager.

#9 Updated by Tobias Brunner over 3 years ago

  • Category set to networkmanager (charon-nm)
  • Status changed from Feedback to Closed
  • Assignee set to Tobias Brunner
  • Resolution set to No change required

OK, thanks for the update.

Also available in: Atom PDF