Project

General

Profile

Issue #2182

strongswan android app does not connect to an ipv6-only server

Added by Petre Rodan almost 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Category:
android
Affected version:
5.4.0
Resolution:
Duplicate

Description

we have a test case scenario in which a device connected to an ipv6-only wireless network (that has NAT64/DNS64 disabled) needs to connect to a strongswan vpn server. if you want I can give you more details on why this is an important scenario for our company.

the client software used is the strongswan android app (strongSwan 5.4.0, Linux 3.10.9-7767647, armv71) that has a connection profile with the following strings defined as server:

scenario 1. server is defined as "bucharest-s15-i01.v6.cg-dialup.net"

client log:
[JOB] spawning 16 worker threads
[LIB] resolving 'bucharest-s15-i01.v6.cg-dialup.net' failed: No address associated with hostname
[IKE] unable to resolve bucharest-s15-i01.v6.cg-dialup.net, initiate aborted
[CFG] failed to initiate tunnel
[MGR] tried to checkin and delete nonexistent IKE_SA

ipv6 resolving done by other software does work on the tablet since web-browsing works just fine towards sites that support ipv6-only operation.

and a AAAA record does exist:
~ $ dig +short AAAA bucharest-s15-i01.v6.cg-dialup.net
2001:4d80:0:42:1501::1

scenario 2. server is defined as "2001:4d80:0:42:1501::1"

client log:
[JOB] spawning 16 worker threads
[IKE] unable to resolve 2001:4d80:0:42:1501::1, initiate aborted
[CFG] failed to initiate tunnel
[MGR] tried to checkin and delete nonexistent IKE_SA

both scenarios should have worked but apparently the android app is not looking for AAAA records (1st case) and it does not recognize an ipv6 address that could directly be used as the "right=" config variable in ipsec.conf (2nd case).

did I miss something?


Related issues

Is duplicate of Feature #892: Android client and IPv6 gatewayClosed15.03.2015

History

#1 Updated by Tobias Brunner almost 4 years ago

  • Is duplicate of Feature #892: Android client and IPv6 gateway added

#2 Updated by Tobias Brunner over 3 years ago

  • Status changed from New to Rejected
  • Assignee set to Tobias Brunner
  • Resolution set to Duplicate

Also available in: Atom PDF