Project

General

Profile

Issue #1429

Cannot create new StrongSwan VPN connection in network manager on Ubuntu 16.04

Added by Anna Godusova over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Category:
networkmanager (charon-nm)
Affected version:
5.3.5
Resolution:
Fixed

Description

It is not possible to create a new StrongSwan VPN connection in network manager in Ubuntu 16.04. I have installed strongswan and network-manager-strongswan packages, but there is no option to choose StrongSwan when adding new connection in Network Connections.

Also, when opening Network Connections, there is an error in syslog:
gnome-session[ 1170]: ** Message: vpn: (strongswan,/etc/NetworkManager/VPN/nm-strongswan-service.name) cannot load legacy-only plugin

Version of network-manager-strongswan is 1.3.1-1ubuntu1, version of strongswan is 5.3.5-1ubuntu3 and version of network-manager is 1.1.93-0ubuntu4.

strongswan-network-manager.png (254 KB) strongswan-network-manager.png Anna Godusova, 22.04.2016 18:40

Related issues

Is duplicate of Issue #1406: vpn unter lubuntu 16.04 mit network-manager herstellenClosed14.04.2016

History

#2 Updated by Tobias Brunner over 5 years ago

  • Is duplicate of Issue #1406: vpn unter lubuntu 16.04 mit network-manager herstellen added

#3 Updated by Tobias Brunner about 5 years ago

  • Category set to networkmanager (charon-nm)
  • Status changed from New to Closed
  • Assignee set to Tobias Brunner
  • Resolution set to Fixed

Fixed with version 1.4.0 of the plugin.

Also available in: Atom PDF