Project

General

Profile

Issue #1250

REKEYING problem between strongSwan and MikroTik router (v6.3.3)

Added by Tobias Feldhaus over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Category:
freebsd
Affected version:
5.3.5
Resolution:
Duplicate

Description

A connection between our MikroTik CloudCore Router with the current firmware (v 6.3.3) and a strongSwan gateway running on FreeBSD 9.3 works as expected, but when the SA gets rekeyed it seems like the old one does not get cleaned up. Flushing the SA's from the MikroTik side did not have any effect on this, restarting the connection via stroke up/down sometimes helps, a restart of the daemon always clears things up.

ipsec.conf (435 Bytes) ipsec.conf Tobias Feldhaus, 31.12.2015 13:25
charon.log (22.2 KB) charon.log Tobias Feldhaus, 31.12.2015 13:25
ipsec_statusall.txt (4.29 KB) ipsec_statusall.txt ipsec statusall output Tobias Feldhaus, 31.12.2015 13:25
mikrotik_webinterface.png (189 KB) mikrotik_webinterface.png MikroTik Webinterface Tobias Feldhaus, 31.12.2015 13:30

Related issues

Is duplicate of Issue #951: p2 SA are not deleted on FreeBSDClosed11.05.2015

History

#1 Updated by Tobias Feldhaus over 4 years ago

can be closed, upgrading to FreeBSD 10.2 resolved the issue

#2 Updated by Noel Kuntze over 4 years ago

Same issue as #951.

#3 Updated by Tobias Brunner over 4 years ago

  • Is duplicate of Issue #951: p2 SA are not deleted on FreeBSD added

#4 Updated by Tobias Brunner over 4 years ago

  • Category set to freebsd
  • Status changed from New to Closed
  • Assignee set to Tobias Brunner
  • Resolution set to Duplicate

Also available in: Atom PDF